Tremendous Catalog - Lululemon US (USD) no longer available in our catalog โ Incident details
Experiencing partially degraded performance
Lululemon US (USD) no longer available in our catalog
Resolved
Degraded performance
Started 1 day agoLasted less than a minute
Affected
Gift Cards - USA
Operational from 6:23 PM to 6:23 PM
Updates
Resolved
Resolved
The product Lululemon US - 5BFZQ7I3A1SP - USD is no longer available in our catalog. Please contact our support team at clients@tremendous.com if you have any questions or concerns.
Identified
Identified
The product Lululemon US - 5BFZQ7I3A1SP - USD is no longer available in our catalog