Tremendous Catalog - Fulfillment delays for Amazon.es (EUR) redemptions – Incident details
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Get updates
Experiencing partially degraded performance
Fulfillment delays for Amazon.es (EUR) redemptions
Resolved
Degraded performance
Started 2 months ago
Lasted 40 minutes
Affected
Gift Cards - Europe
Degraded performance from 6:05 AM to 6:45 AM
Updates
Resolved
October 10, 2024 at 6:45 AM
Resolved
October 10, 2024 at 6:45 AM
This incident has been resolved.
Identified
October 10, 2024 at 6:05 AM
Identified
October 10, 2024 at 6:05 AM
Redemptions to the following products are currently delayed: Amazon.es - 4W4BSH0K22R7 - EUR