Tremendous Catalog - Amazon SGD (SGD) temporarily unavailable in our catalog – Incident details

Experiencing partially degraded performance

Amazon SGD (SGD) temporarily unavailable in our catalog

Resolved
Degraded performance
Started 8 days agoLasted 35 minutes

Affected

Gift Cards - Asia & Oceania

Degraded performance from 12:45 PM to 1:20 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified
    The product Amazon SGD - G8C0RDYYQZSM - SGD was removed from our catalog. We are monitoring the product status with the fulfillment provider and should have it back online as soon as it becomes available again.