Tremendous Catalog - Home Centre KWD (KWD) temporarily unavailable in our catalog – Incident details

Experiencing partially degraded performance

Home Centre KWD (KWD) temporarily unavailable in our catalog

Resolved
Degraded performance
Started 7 days agoLasted 1 day

Affected

Gift Cards - Africa & Middle East

Degraded performance from 6:40 AM to 6:40 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved. The product is back online.
  • Identified
    Identified
    The product Home Centre KWD - CHCJ416HABK7 - KWD was removed from our catalog. We are monitoring the product status with the fulfillment provider and should have it back online as soon as it becomes available again.