Tremendous Catalog - Fulfillment delays for PayPal International (USD) and 2 other products – Incident details

Experiencing partially degraded performance

Fulfillment delays for PayPal International (USD) and 2 other products

Resolved
Degraded performance
Started 12 days agoLasted about 2 hours

Affected

Monetary Options

Degraded performance from 2:15 PM to 4:20 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified
    Redemptions to the following products are currently delayed: PayPal International - O7VZ5WQOCUQM PayPal USA - KV934TZ93NQM - USD Venmo - TKIHHHAJU20C - USD