Tremendous Catalog - Fulfillment errors for Nintendo Switch (EUR) redemptions – Incident details

Experiencing partially degraded performance

Fulfillment errors for Nintendo Switch (EUR) redemptions

Resolved
Degraded performance
Started 24 days agoLasted 19 days

Affected

Gift Cards - Europe

Degraded performance from 2:05 PM to 11:17 AM

Updates
  • Resolved
    Resolved

    Redemptions are now succeeding. This incident has been resolved.

  • Identified
    Identified
    Due to internal issues with an upstream fulfillment provider, redemptions for the following products are experiencing errors: Nintendo Switch - HHO3RLW6KS89 - EUR