Tremendous Catalog - Fulfillment errors for Nintendo Switch (EUR) redemptions โ€“ Incident details

Experiencing partially degraded performance

Fulfillment errors for Nintendo Switch (EUR) redemptions

Resolved
Degraded performance
Started about 1 month agoLasted about 1 month

Affected

Gift Cards - Europe

Degraded performance from 7:15 AM to 11:23 AM

Updates
  • Resolved
    Resolved

    Redemptions are now succeeding. This incident has been resolved.

  • Identified
    Identified
    Due to internal issues with an upstream fulfillment provider, redemptions for the following products are experiencing errors: Nintendo Switch - 2ZSHRDX3K8DC - EUR