Tremendous Catalog - Fulfillment errors for Amazon Pay India (INR) redemptions โ Incident details
Experiencing partially degraded performance
Fulfillment errors for Amazon Pay India (INR) redemptions
Resolved
Degraded performance
Started 15 days agoLasted about 18 hours
Affected
Gift Cards - Asia & Oceania
Degraded performance from 5:05 PM to 10:40 AM
Updates
Resolved
Resolved
Redemptions are now succeeding. This incident has been resolved.
Identified
Identified
Due to internal issues with an upstream fulfillment provider, redemptions for the following products are experiencing errors:
Amazon Pay India - 3H9M8ZMR5ZDM - INR